Friday, September 17, 2010

Abiwidget -------> gnocl::abiwidget

During one of those little breaks between research and writing up I decided to take a look at building the Abiwidget test. I was expecting a whole pile of hassle and unresolved compile dependencies but no! Simply installed the development files from the OpenSuse repositories saved the demo app from the Abiword wiki, modified the make to reflect the inclusion of the 2.8 libraries and bam! After a brief compilation it all worked! In fact writing this blog post has taken more time! Tonight, I think that I'll wrap the widget creation code into a gnocl package. There's so much functionality here!

If there's going to be a tricky part to this all it will be plug-in support.



 

No comments: